openssl: fix architecture specified when configuring openssl
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 13 Oct 2008 08:10:35 +0000 (08:10 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 13 Oct 2008 08:10:35 +0000 (08:10 -0000)
This patch will default to linux-generic32, unless a known optimized
architecture is selected.

As of today it will select optimized config for; avr32, ia64, powerpc and
x86_64.

This fixes bug #5344.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/openssl/openssl.mk

index b8c488f5f7618020c7de5c93558bc17521c5f5c3..5e607fc9071b0c9f755e45f19118df0fd5c5aff7 100644 (file)
@@ -6,12 +6,20 @@
 OPENSSL_VERSION:=0.9.8g
 OPENSSL_SITE:=http://www.openssl.org/source
 
-OPENSSL_TARGET_ARCH:=
-ifeq ($(BR2_i386),y)
-OPENSSL_TARGET_ARCH:=generic32
+OPENSSL_TARGET_ARCH=generic32
+
+# Some architectures are optimized in OpenSSL
+ifeq ($(BR2_ARCH),avr32)
+OPENSSL_TARGET_ARCH=avr32
+endif
+ifeq ($(BR2_ARCH),ia64)
+OPENSSL_TARGET_ARCH=ia64
+endif
+ifeq ($(BR2_ARCH),powerpc)
+OPENSSL_TARGET_ARCH=ppc
 endif
-ifeq ($(OPENSSL_TARGET_ARCH),)
-OPENSSL_TARGET_ARCH:=$(ARCH)
+ifeq ($(BR2_ARCH),x86_64)
+OPENSSL_TARGET_ARCH=x86_64
 endif
 
 OPENSSL_INSTALL_STAGING = YES