boot/lpc32xxcdl: switch upstream location
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Dec 2020 10:56:53 +0000 (11:56 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Dec 2020 17:11:49 +0000 (18:11 +0100)
The upstream git tree has disappeared, but a ZIP file is still hosted
somewhere at NXP. The content of that zip file has been verified to be
100% identical to the tarball we hosted on s.b.o.

As this is a zip file, we can't use the generic extract commands, and
must come up with our own. As such, it no longer makes sense to fix the
CRLF as a post-extract hook; this is moved to the extract command.

Add a hash file while at it.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
boot/lpc32xxcdl/lpc32xxcdl.hash [new file with mode: 0644]
boot/lpc32xxcdl/lpc32xxcdl.mk

diff --git a/boot/lpc32xxcdl/lpc32xxcdl.hash b/boot/lpc32xxcdl/lpc32xxcdl.hash
new file mode 100644 (file)
index 0000000..8c6b73d
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  ded3fa936a96d3fb8188ca6214f57b5208bd49e5416bd69f38bfc810b34197bc  lpc32xx_cdl-v2.11.zip
index 30afed050b1c7a4c8acf86e7a6e8529d7d8c944d..9f5cd27f508fb34ccc5e81f7fb27f5a8e12af69f 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-LPC32XXCDL_VERSION = lpc32xx_cdl_v2.11
-LPC32XXCDL_SITE = http://git.lpcware.com/lpc3xxx_cdl.git
-LPC32XXCDL_SITE_METHOD = git
+LPC32XXCDL_VERSION = 2.11
+LPC32XXCDL_SOURCE = lpc32xx_cdl-v$(LPC32XXCDL_VERSION).zip
+LPC32XXCDL_SITE = https://community.nxp.com/pwmxy87654/attachments/pwmxy87654/lpcware-archive/61/2
 
 LPC32XXCDL_INSTALL_TARGET = NO
 LPC32XXCDL_INSTALL_IMAGES = YES
@@ -45,13 +45,14 @@ LPC32XXCDL_BOARD_STARTUP_DIR = \
 # Source files are with dos newlines, which our patch infrastructure doesn't
 # handle. Work around it by converting the affected files to unix newlines
 # before patching
-define LPC32XXCDL_DOS2UNIX_FOR_PATCH
+define LPC32XXCDL_EXTRACT_CMDS
+       unzip $(LPC32XXCDL_DL_DIR)/$(LPC32XXCDL_SOURCE) -d $(@D)
+       mv $(@D)/lpc3xxx_cdl/* $(@D)
+       rmdir $(@D)/lpc3xxx_cdl/
        sed -n 's|^[+-]\{3\} [^/]\+\([^ \t]*\)\(.*\)|$(@D)\1|p' \
                boot/lpc32xxcdl/*.patch| sort -u | xargs $(SED) 's/\x0D$$//'
 endef
 
-LPC32XXCDL_POST_EXTRACT_HOOKS += LPC32XXCDL_DOS2UNIX_FOR_PATCH
-
 define LPC32XXCDL_BUILD_CMDS
        $(MAKE1) $(LPC32XXCDL_BUILD_FLAGS) -C $(@D)
        $(MAKE1) $(LPC32XXCDL_BUILD_FLAGS) -C $(@D)/$(LPC32XXCDL_BOARD_STARTUP_DIR)/Burners/$(LPC32XXCDL_KICKSTART_BURNER)