iptables: install to staging
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 10 Jan 2011 17:41:24 +0000 (14:41 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Jan 2011 23:19:24 +0000 (00:19 +0100)
Install iptables to staging so we can build iproute2 with filtering.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/iptables/iptables.mk

index 1ec2c856ce16d7da63b2a07f0dab6a00f2e060ca..b06ab71d9d115007198b09204c6ef74601f6c50d 100644 (file)
@@ -3,9 +3,12 @@
 # iptables
 #
 #############################################################
+
 IPTABLES_VERSION = 1.4.10
 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
+IPTABLES_INSTALL_STAGING = YES
+IPTABLES_AUTORECONF = YES
 IPTABLES_DEPENDENCIES = host-pkg-config
 
 IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(LINUX_HEADERS_DIR)
@@ -13,8 +16,6 @@ ifneq ($(BR2_INET_IPV6),y)
 IPTABLES_CONF_OPT += --disable-ipv6
 endif
 
-IPTABLES_AUTORECONF = YES
-
 define IPTABLES_TARGET_SYMLINK_CREATE
        ln -sf iptables-multi $(TARGET_DIR)/usr/sbin/iptables
        ln -sf iptables-multi $(TARGET_DIR)/usr/sbin/iptables-save