omniorb: force python interperter
authorSamuel Martin <s.martin49@gmail.com>
Mon, 14 Apr 2014 21:05:50 +0000 (23:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Apr 2014 21:14:11 +0000 (23:14 +0200)
Omniorb build-system requires python2 interpreter.

By default, it looks for python program, which may fallback on the system
python interpreter in case python is disabled and python3 is enabled.

So, this patch enforces the python interpreter to python2 built by
Buildroot.

Fixes:
  http://autobuild.buildroot.org/results/b4f/b4f3a2602ba0224ac3253c4bf6ed87ec045df772/

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/omniorb/omniorb.mk

index fa2492f2b9b31b2e2244681dc5e46943418c6e6c..5b58da50019ec5b4d1a5aa8060556c1d03326e39 100644 (file)
@@ -14,6 +14,10 @@ OMNIORB_DEPENDENCIES = host-omniorb
 HOST_OMNIORB_DEPENDENCIES = host-python
 OMNIORB_INSTALL_TARGET = YES
 
+# omniorb is not python3 friendly, so force the python interpreter
+OMNIORB_CONF_OPT = ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
+HOST_OMNIORB_CONF_OPT = ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
+
 # Defaulting long double support to a safe option for the
 # mix of embedded targets, this could later be automated
 # based on checking the capability of the cross toolchain