mpd: add pulseaudio support
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Oct 2011 14:21:47 +0000 (16:21 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Oct 2011 15:13:03 +0000 (17:13 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/mpd/Config.in
package/multimedia/mpd/mpd.mk

index 6de1e5b4870e1e41d10163feaf21099c6b1686fa..27bd309b430dab4615c55a3b5e587d360d855353 100644 (file)
@@ -30,6 +30,12 @@ config BR2_PACKAGE_MPD_AO
        help
          Enable libao output support.
 
+config BR2_PACKAGE_MPD_PULSEAUDIO
+       bool "pulseaudio"
+       select BR2_PACKAGE_PULSEAUDIO
+       help
+         Enable pulseaudio output support.
+
 config BR2_PACKAGE_MPD_BZIP2
        bool "bzip2"
        select BR2_PACKAGE_BZIP2
index 0bf38a277194bbb5f4c6cf241a76d821a5c9ab92..b29b9f7a59d0a57c0136bbaafb9509705bafa216 100644 (file)
@@ -22,6 +22,11 @@ MPD_DEPENDENCIES += libao
 MPD_CONF_OPT += --enable-ao
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_PULSEAUDIO),y)
+MPD_DEPENDENCIES += pulseaudio
+MPD_CONF_OPT += --enable-pulse
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_BZIP2),y)
 MPD_DEPENDENCIES += bzip2
 MPD_CONF_OPT += --enable-bzip2