botan: fix build on uclibc
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 11 Sep 2018 18:54:36 +0000 (20:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 12 Sep 2018 08:39:09 +0000 (10:39 +0200)
uclibc does not have sys/auxv.h so disable getauxval

Fixes:
 - http://autobuild.buildroot.org/results/0000636025b843ab343dc45ccd29979325aff428

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk

index e352fab6c94c4780d04d28bb9714f16bed4ff52b..4788617d4ac8e5806b2d5efbe1f85cb9172e7a1c 100644 (file)
@@ -40,6 +40,10 @@ else
 BOTAN_CONF_OPTS += --without-stack-protector
 endif
 
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+BOTAN_CONF_OPTS += --without-os-feature=getauxval
+endif
+
 ifeq ($(BR2_PACKAGE_BOOST),y)
 BOTAN_DEPENDENCIES += boost
 BOTAN_CONF_OPTS += --with-boost