ustream-ssl: new package
authorRahul Jain <Rahul.Jain@imgtec.com>
Mon, 17 Oct 2016 11:02:23 +0000 (16:32 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Nov 2016 12:54:41 +0000 (13:54 +0100)
ustream-ssl has support for polarssl and cyassl
but since polarssl is made obsolete by mbedtls and cyassl
is not present in buildroot, we have not added support for it.

Signed-off-by: Rahul Bedarkar <Rahul.Bedarkar@imgtec.com>
Signed-off-by: Rahul Jain <Rahul.Jain@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/ustream-ssl/Config.in [new file with mode: 0644]
package/ustream-ssl/ustream-ssl.mk [new file with mode: 0644]

index 9ed296f2d9236717e72b3d29e191a3f46b169383..a24110e8ac9d10a4e618d26633eabb7ee13d9f8f 100644 (file)
@@ -912,6 +912,7 @@ menu "Crypto"
        source "package/polarssl/Config.in"
        source "package/tinydtls/Config.in"
        source "package/trousers/Config.in"
+       source "package/ustream-ssl/Config.in"
 endmenu
 
 menu "Database"
diff --git a/package/ustream-ssl/Config.in b/package/ustream-ssl/Config.in
new file mode 100644 (file)
index 0000000..540e436
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_USTREAM_SSL
+       bool "ustream-ssl"
+       depends on !BR2_STATIC_LIBS #libubox
+       select BR2_PACKAGE_LIBUBOX
+       select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_MBEDTLS
+       help
+         ustream SSL wrapper
+
+         https://git.openwrt.org/?p=project/ustream-ssl.git;a=summary
+
+comment "ustream-ssl needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/ustream-ssl/ustream-ssl.mk b/package/ustream-ssl/ustream-ssl.mk
new file mode 100644 (file)
index 0000000..b83d129
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# ustream-ssl
+#
+################################################################################
+
+USTREAM_SSL_VERSION = ec80adaa1b47f28d426fa19c692011ce60b992d6
+USTREAM_SSL_SITE = git://git.openwrt.org/project/ustream-ssl.git
+USTREAM_SSL_LICENSE = ISC
+USTREAM_SSL_LICENSE_FILES = ustream-ssl.h
+USTREAM_SSL_INSTALL_STAGING = YES
+USTREAM_SSL_DEPENDENCIES = libubox
+
+ifeq ($(BR2_PACKAGE_MBEDTLS),y)
+USTREAM_SSL_DEPENDENCIES += mbedtls
+USTREAM_SSL_CONF_OPTS += -DMBEDTLS=ON
+else
+USTREAM_SSL_DEPENDENCIES += openssl
+endif
+
+$(eval $(cmake-package))