package/protobuf: fix build failure due to missing -mcmodel=large
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Mon, 26 Jul 2021 22:34:34 +0000 (00:34 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 17 Aug 2021 21:11:44 +0000 (23:11 +0200)
When building protobuf for or1k -mcmodel=large is needed to link, so let's
add that gcc option in case we're building for or1k.

Upstream gcc doesn't have the -mcmodel=large option for or1k, but all
released Buildroot gcc versions have the patch to add it, so that's
fine.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Reviewed-by: Maxim Kochetkov <fido_max@inbox.ru>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/protobuf/protobuf.mk

index 492917c5e89663896dac09ca7ea4d9960e52b256..75791fade2a5d00c099d10034837d95fcf5f22bf 100644 (file)
@@ -24,6 +24,10 @@ ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
 PROTOBUF_CXXFLAGS += -O0
 endif
 
+ifeq ($(BR2_or1k),y)
+PROTOBUF_CXXFLAGS += -mcmodel=large
+endif
+
 PROTOBUF_CONF_ENV = CXXFLAGS="$(PROTOBUF_CXXFLAGS)"
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)