package/fail2ban: The (host-python3) 2to3 utility needs to be present
authorPascal de Bruijn <p.debruijn@unilogic.nl>
Wed, 26 Feb 2020 08:28:18 +0000 (09:28 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Feb 2020 15:35:43 +0000 (16:35 +0100)
During _POST_PATCH_HOOKS _DEPENDANCIES aren't guaranteed to be built,
however during _PRE_CONFIGURE_HOOKS they should be built.

Should fix:
http://autobuild.buildroot.net/results/dd8e225e2a49cfa6735bed11459007003a37c137/
http://autobuild.buildroot.net/results/e688c3652bd474ac682984e2e5947701942f0f57/

Cc: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/fail2ban/fail2ban.mk

index 6f023b48a181cfeaec4506f948ecd70e21638b84..a0a2dc704b08918557ff0ef9173a3654caa5c3bc 100644 (file)
@@ -15,7 +15,9 @@ define FAIL2BAN_PYTHON_2TO3
        $(HOST_DIR)/bin/2to3 --write --nobackups --no-diffs $(@D)/bin/* $(@D)/fail2ban
 endef
 FAIL2BAN_DEPENDENCIES += host-python3
-FAIL2BAN_POST_PATCH_HOOKS += FAIL2BAN_PYTHON_2TO3
+# We can't use _POST_PATCH_HOOKS because dependencies are not guaranteed
+# to build and install before _POST_PATCH_HOOKS run.
+FAIL2BAN_PRE_CONFIGURE_HOOKS += FAIL2BAN_PYTHON_2TO3
 endif
 
 define FAIL2BAN_FIX_DEFAULT_CONFIG