libcgicc: fix package after autotools infrastructure conversion
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 May 2010 20:40:31 +0000 (22:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 May 2010 20:34:27 +0000 (22:34 +0200)
The patch had an incorrect name, and the libtool patch was applied
while it shouldn't, and the package wasn't autoreconfed while the
patch changes some Makefile.am files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libcgicc/cgicc-3.2.9-disable-documentation-option.patch [deleted file]
package/libcgicc/libcgicc-3.2.9-disable-documentation-option.patch [new file with mode: 0644]
package/libcgicc/libcgicc.mk

diff --git a/package/libcgicc/cgicc-3.2.9-disable-documentation-option.patch b/package/libcgicc/cgicc-3.2.9-disable-documentation-option.patch
deleted file mode 100644 (file)
index a7b04a8..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-Index: cgicc-3.2.9/Makefile.am
-===================================================================
---- cgicc-3.2.9.orig/Makefile.am       2010-02-25 16:34:06.000000000 +0100
-+++ cgicc-3.2.9/Makefile.am    2010-02-25 16:34:14.000000000 +0100
-@@ -8,9 +8,15 @@
- DEMO =
- endif
-+if DOC
-+DOCDIR = doc
-+else
-+DOC =
-+endif
-+
- ACLOCAL_AMFLAGS= 
--SUBDIRS = cgicc doc support $(DEMO)
-+SUBDIRS = cgicc $(DOCDIR) support $(DEMO)
- CLEANFILES = *~
-Index: cgicc-3.2.9/configure.ac
-===================================================================
---- cgicc-3.2.9.orig/configure.ac      2010-02-25 16:34:06.000000000 +0100
-+++ cgicc-3.2.9/configure.ac   2010-02-25 16:45:46.000000000 +0100
-@@ -17,9 +17,23 @@
- AC_PROG_CXX
- AC_PROG_INSTALL
- AC_PROG_LIBTOOL
--AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, /bin/echo)
-+AC_ARG_ENABLE(doc, 
-+  [  --enable-doc          build doc [[default=yes]]],
-+  [case "${enableval}" in
-+    yes) cgicc_doc=yes ;;
-+    no)  cgicc_doc=no ;;
-+    *) AC_MSG_ERROR(bad value ${enableval} for --enable-doc) ;;
-+  esac], cgicc_doc=yes)
-+
-+if test "$cgicc_doc" = yes; then
-+ AC_CHECK_PROG(DOXYGEN, doxygen, doxygen)
-+ if test -z "$DOXYGEN" ; then
-+   AC_MSG_ERROR([Doxygen is required to build the documentation])
-+ fi
-+fi
-+AM_CONDITIONAL(DOC, test "$cgicc_doc" = yes)
- dnl Determine host system type
diff --git a/package/libcgicc/libcgicc-3.2.9-disable-documentation-option.patch b/package/libcgicc/libcgicc-3.2.9-disable-documentation-option.patch
new file mode 100644 (file)
index 0000000..a7b04a8
--- /dev/null
@@ -0,0 +1,50 @@
+Index: cgicc-3.2.9/Makefile.am
+===================================================================
+--- cgicc-3.2.9.orig/Makefile.am       2010-02-25 16:34:06.000000000 +0100
++++ cgicc-3.2.9/Makefile.am    2010-02-25 16:34:14.000000000 +0100
+@@ -8,9 +8,15 @@
+ DEMO =
+ endif
++if DOC
++DOCDIR = doc
++else
++DOC =
++endif
++
+ ACLOCAL_AMFLAGS= 
+-SUBDIRS = cgicc doc support $(DEMO)
++SUBDIRS = cgicc $(DOCDIR) support $(DEMO)
+ CLEANFILES = *~
+Index: cgicc-3.2.9/configure.ac
+===================================================================
+--- cgicc-3.2.9.orig/configure.ac      2010-02-25 16:34:06.000000000 +0100
++++ cgicc-3.2.9/configure.ac   2010-02-25 16:45:46.000000000 +0100
+@@ -17,9 +17,23 @@
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+-AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, /bin/echo)
++AC_ARG_ENABLE(doc, 
++  [  --enable-doc          build doc [[default=yes]]],
++  [case "${enableval}" in
++    yes) cgicc_doc=yes ;;
++    no)  cgicc_doc=no ;;
++    *) AC_MSG_ERROR(bad value ${enableval} for --enable-doc) ;;
++  esac], cgicc_doc=yes)
++
++if test "$cgicc_doc" = yes; then
++ AC_CHECK_PROG(DOXYGEN, doxygen, doxygen)
++ if test -z "$DOXYGEN" ; then
++   AC_MSG_ERROR([Doxygen is required to build the documentation])
++ fi
++fi
++AM_CONDITIONAL(DOC, test "$cgicc_doc" = yes)
+ dnl Determine host system type
index c2f80b6c730761a4817ed3f6f0feb42b41c845bd..b281eed16fab08e12f0c1427d8dc27cf9384e7a5 100644 (file)
@@ -7,6 +7,8 @@ LIBCGICC_VERSION=3.2.9
 LIBCGICC_SITE=$(BR2_GNU_MIRROR)/cgicc
 LIBCGICC_SOURCE=cgicc-$(LIBCGICC_VERSION).tar.gz
 LIBCGICC_INSTALL_STAGING=YES
+LIBCGICC_LIBTOOL_PATCH=NO
+LIBCGICC_AUTORECONF=YES
 
 LIBCGICC_CONF_OPT = \
        --disable-demos \