mpfr: use patch-kernel to apply downloaded patch
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 24 Sep 2009 15:14:31 +0000 (17:14 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 24 Sep 2009 15:14:31 +0000 (17:14 +0200)
Reported by Emmanuel Riou <riou.emmanuel@googlemail.com>.

With the recent change to use $(TOPDIR)/dl as default for $(DL_DIR)
(416323e93), DL_DIR is now a relative path (./dl), which breaks the
mpfr patch handling as it changes dir.

Fix is by using patch-kernel instead of calling patch, which does
the right thing.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/mpfr/mpfr.mk

index 4bd100cffbcb70d619ab067ad3e6b6bb8a7a3b13..b0a3cf8c753bb8cf729afbd62d66fdaadbde353d 100644 (file)
@@ -34,7 +34,7 @@ $(MPFR_DIR)/.unpacked: $(DL_DIR)/$(MPFR_SOURCE) $(MPFR_PATCH_SOURCE)
        toolchain/patch-kernel.sh $(MPFR_DIR) package/mpfr/ \*.patch
        $(CONFIG_UPDATE) $(@D)
 ifneq ($(MPFR_PATCH),)
-       ( cd $(MPFR_DIR); patch -p1 -N -Z < $(MPFR_PATCH_SOURCE); )
+       toolchain/patch-kernel.sh $(MPFR_DIR) $(DL_DIR)/ $(MPFR_PATCH_FILE)
 endif
        touch $@