New package: python-dpkt
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 4 Jan 2012 11:30:02 +0000 (12:30 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 7 Jan 2012 19:56:33 +0000 (20:56 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/python-dpkt/Config.in [new file with mode: 0644]
package/python-dpkt/python-dpkt.mk [new file with mode: 0644]

index 78174e5acd75d488e3d63c1a8024ed2638d2c2d0..d70f9b05c3f3318eb15151bfc6ef99f1712fa8d2 100644 (file)
@@ -239,6 +239,7 @@ source "package/php/Config.in"
 source "package/python/Config.in"
 if BR2_PACKAGE_PYTHON
 menu "external python modules"
+source "package/python-dpkt/Config.in"
 source "package/python-mad/Config.in"
 source "package/python-serial/Config.in"
 endmenu
diff --git a/package/python-dpkt/Config.in b/package/python-dpkt/Config.in
new file mode 100644 (file)
index 0000000..aac9f09
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PYTHON_DPKT
+       bool "python-dpkt"
+       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON_ZLIB
+       help
+         Fast, simple packet creation / parsing, with definitions
+         for the basic TCP/IP protocols.
+
+         http://code.google.com/p/dpkt/
+
+
diff --git a/package/python-dpkt/python-dpkt.mk b/package/python-dpkt/python-dpkt.mk
new file mode 100644 (file)
index 0000000..7ac873c
--- /dev/null
@@ -0,0 +1,22 @@
+#############################################################
+#
+# python-dpkt
+#
+#############################################################
+
+PYTHON_DPKT_VERSION = 1.7
+PYTHON_DPKT_SOURCE  = dpkt-$(PYTHON_DPKT_VERSION).tar.gz
+PYTHON_DPKT_SITE    = http://dpkt.googlecode.com/files
+
+PYTHON_DPKT_DEPENDENCIES = python
+
+define PYTHON_DPKT_BUILD_CMDS
+       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_DPKT_INSTALL_TARGET_CMDS
+       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS))
+