kvm-unit-tests: add gcc version dependencies
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Oct 2016 19:12:03 +0000 (21:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Oct 2016 19:13:54 +0000 (21:13 +0200)
On x86 (both i386 and x86_64), the kvm-unit-tests code uses
__builtin_reachable, which appeared in gcc 4.5. This commit adds the
relevant dependencies to kvm-unit-tests:

 - on i386, we need gcc 4.5 as the target compiler

 - on x86-64, we need gcc 4.5 as the host compiler, because we use the
   host compiler to build kvm-unit-tests for this architecture

Fixes:

  http://autobuild.buildroot.net/results/21340a7e6494e23adb2fe8dc6253ab220c380fec/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kvm-unit-tests/Config.in

index d72c734e786baf233ddbf47f7dd86454325dafcf..f704a8e0c3533bfd7e2342096101d50ded937e1c 100644 (file)
@@ -1,8 +1,14 @@
 config BR2_PACKAGE_KVM_UNIT_TESTS
        bool "kvm-unit-tests"
        select BR2_HOSTARCH_NEEDS_IA32_COMPILER if BR2_x86_64=y
-       depends on BR2_arm || BR2_i386 || BR2_powerpc64 || \
-               BR2_powerpc64le || BR2_x86_64
+       # on i386 and x86-64, __builtin_reachable is used, so we need
+       # gcc 4.5 at least. on i386, we use the target gcc, while on
+       # x86-64 we use the host gcc (see .mk file for details)
+       depends on BR2_arm || \
+               (BR2_i386 && BR2_TOOLCHAIN_GCC_AT_LEAST_4_5) || \
+               BR2_powerpc64 || \
+               BR2_powerpc64le || \
+               (BR2_x86_64 && BR2_HOST_GCC_AT_LEAST_4_5)
        help
          kvm-unit-tests is a project as old as KVM. As its name
          suggests, it's purpose is to provide unit tests for KVM. The