Revert "package/kodi: optimise for RPi2"
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 May 2016 07:44:42 +0000 (09:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 May 2016 13:33:39 +0000 (15:33 +0200)
Optimised support for the RPi-2 was only introduced in Krypton, the next
release of Kodi. Jarvis, the current release, does not have this
support.

This reverts commit ef37472b20894c99cad758397f3cd6b90f933df1.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: BenoƮt Mauduit <bmauduit@beneth.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/kodi.mk

index e812b5031d264212f1c30c7cfa474bc87b9622a2..e163c240189b042a76358c95bfdd3b74d7135a26 100644 (file)
@@ -47,14 +47,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 KODI_DEPENDENCIES += rpi-userland
-# Kodi has specific configuration flags for RPi/RPi2. Configure for a
-# RPi2 when we're sure, fallback to RPi otherwise.
-ifeq ($(BR2_cortex_a7),y)
-KODI_CONF_OPTS += --with-platform=raspberry-pi2
-else
-KODI_CONF_OPTS += --with-platform=raspberry-pi
-endif
-KODI_CONF_OPTS += --enable-player=omxplayer
+KODI_CONF_OPTS += --with-platform=raspberry-pi --enable-player=omxplayer
 KODI_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
        -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux" \
        LIBS="-lvcos -lvchostif"