package/nfs-utils: fix build with libtirpc
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 17 Jul 2021 13:44:36 +0000 (15:44 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 Jul 2021 14:05:25 +0000 (16:05 +0200)
Help nfs-utils to find the path of libtirpc

Fixes:
 - http://autobuild.buildroot.org/results/a5eaf19f58729c4c00a2131b6a0c378c0fc0effb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - take the opportunity to move HOST_NFS_UTILS_DEPENDENCIES
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/nfs-utils/nfs-utils.mk

index ab000e1ead7bc10da297d7ae0a4efe0051243781..51a35028e2eafb5ae2c6c2bef717554f2cc9d3aa 100644 (file)
@@ -23,7 +23,10 @@ NFS_UTILS_CONF_OPTS = \
        --with-statedir=/run/nfs \
        --with-rpcgen=$(HOST_DIR)/bin/rpcgen
 
+HOST_NFS_UTILS_DEPENDENCIES = host-pkgconf host-libtirpc
+
 HOST_NFS_UTILS_CONF_OPTS = \
+       --enable-tirpc \
        --disable-nfsv4 \
        --disable-nfsv41 \
        --disable-gss \
@@ -32,10 +35,9 @@ HOST_NFS_UTILS_CONF_OPTS = \
        --without-tcp-wrappers \
        --with-statedir=/run/nfs \
        --disable-caps \
-       --disable-tirpc \
        --without-systemd \
-       --with-rpcgen=internal
-HOST_NFS_UTILS_DEPENDENCIES = host-pkgconf host-libtirpc
+       --with-rpcgen=internal \
+       --with-tirpcinclude=$(HOST_DIR)/include/tirpc
 
 NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPCDEBUG) += usr/sbin/rpcdebug
 NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPC_LOCKD) += usr/sbin/rpc.lockd