Makefile: also unexport PKG_CONFIG_LIBDIR
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 11 Sep 2013 12:15:15 +0000 (14:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 11 Sep 2013 12:15:15 +0000 (14:15 +0200)
Similar to how we do it for _PATH / _SYSROOT_DIR. Buildroot gets fairly
confused if the user has set up a custom PKG_CONFIG_LIBDIR, so ensure
it gets unset.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 3ca7313942d054bdb5c3254803edb498fb753c0e..861059284b84cd1a0b4f091d7471a91c4f2919f3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -175,6 +175,7 @@ export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
 # Make sure pkg-config doesn't look outside the buildroot tree
 unexport PKG_CONFIG_PATH
 unexport PKG_CONFIG_SYSROOT_DIR
+unexport PKG_CONFIG_LIBDIR
 
 # Having DESTDIR set in the environment confuses the installation
 # steps of some packages.