package/pkg-meson: <pkg>_SUBDIR cleanup
authorLionel Orry <lionel.orry@gmail.com>
Thu, 11 Oct 2018 09:57:53 +0000 (11:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 16:21:28 +0000 (17:21 +0100)
No functional change is brought by this modification.

This patch:
* removes a redundant <pkg>_SRCDIR declaration (already defined in
  pkg-generic.mk)
* documents the usage of <pkg>_SUBDIR in the meson-specific section of
  the manual.

Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
docs/manual/adding-packages-meson.txt
package/pkg-meson.mk

index 549319b192a09f8649005691391e5006747541ce..30c338f486735952496cb5b7b563a3865cfdccb4 100644 (file)
@@ -85,6 +85,12 @@ A few additional variables, specific to the Meson infrastructure, can also be
 defined. Many of them are only useful in very specific cases, typical packages
 will therefore only use a few of them.
 
+* +FOO_SUBDIR+ may contain the name of a subdirectory inside the
+  package that contains the main meson.build file. This is useful,
+  if for example, the main meson.build file is not at the root of
+  the tree extracted by the tarball. If +HOST_FOO_SUBDIR+ is not
+  specified, it defaults to +FOO_SUBDIR+.
+
 * +FOO_CONF_ENV+, to specify additional environment variables to pass to
   +meson+ for the configuration step. By default, empty.
 
index 256e5645e4e9d91a0e47a06cbfc4597cd964d2bb..a637299476c9bdff756c1238ff321e9f856474f2 100644 (file)
@@ -48,7 +48,6 @@ define inner-meson-package
 $(2)_CONF_ENV          ?=
 $(2)_CONF_OPTS         ?=
 $(2)_NINJA_ENV         ?=
-$(2)_SRCDIR            = $$($(2)_DIR)/$$($(2)_SUBDIR)
 
 #
 # Configure step. Only define it if not already defined by the package