host-qemu: add support for vde2
authorSimon Maes <simonn.maes@gmail.com>
Sun, 3 Jul 2016 22:24:23 +0000 (00:24 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Jul 2016 09:29:31 +0000 (11:29 +0200)
Additional configuration for host-qemu package:
- Enable VDE2 support for qemu

Signed-off-by: Simon Maes <simonn.maes@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qemu/Config.in.host
package/qemu/qemu.mk

index 227749af0e1f1bdd538ba5e8c1fb5f53b33427b0..b3eb5906cc8e02b01949ab5f4cb496d50edbf83e 100644 (file)
@@ -31,4 +31,11 @@ config BR2_PACKAGE_HOST_QEMU_LINUX_USER_MODE
          Enables the build of the user-land emulator, which allows to
          run user-space applications.
 
+config BR2_PACKAGE_HOST_QEMU_VDE2
+       bool "VDE2 support"
+       help
+         Enables VDE2 support. VDE2 stands for Virtual Distributed
+         Ethernet and can be used to create virtual switches to
+         "plug" both physical and virtual machines in them.
+
 endif
index 5c3cfeacc3c838484a7258556dfcd963f36d58a3..3ca09583ed902e3ee1be09733c17577907f84fa4 100644 (file)
@@ -105,6 +105,11 @@ else # BR2_PACKAGE_HOST_QEMU_LINUX_USER_MODE
 HOST_QEMU_OPTS += --disable-linux-user
 endif # BR2_PACKAGE_HOST_QEMU_LINUX_USER_MODE
 
+ifeq ($(BR2_PACKAGE_HOST_QEMU_VDE2),y)
+HOST_QEMU_OPTS += --enable-vde
+HOST_QEMU_DEPENDENCIES += host-vde2
+endif
+
 define HOST_QEMU_CONFIGURE_CMDS
        cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure    \
                --target-list="$(HOST_QEMU_TARGETS)"    \