rtai, xenomai: use the pre patch hook point
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Sep 2011 20:10:53 +0000 (22:10 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Sep 2011 20:18:16 +0000 (22:18 +0200)
The post extract hook point is not really correct as what RTAI and
Xenomai extensions are doing is patching the kernel.

The post patch hook point doesn't work, because RTAI and Xenomai
patches would be applied *after* all other patches, while it sounds
more logical to apply them first, and *then* allow the user to apply
some platform/board specific patches if needed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux-ext-rtai.mk
linux/linux-ext-xenomai.mk

index a54230d321ab84c604e5cc5db4c64db5a612dfbb..150f9e897932861563190d211b0e39f69bb094b9 100644 (file)
@@ -42,6 +42,6 @@ define RTAI_PREPARE_KERNEL
 endef
 endif
 
-LINUX_POST_PATCH_HOOKS += RTAI_PREPARE_KERNEL
+LINUX_PRE_PATCH_HOOKS += RTAI_PREPARE_KERNEL
 
 endif #BR2_LINUX_EXT_RTAI
index e855deddf8b248ff5097f7f2ef7f8617c5ecabb3..9b6772e23874cc46d18f29ec595c510393130435 100644 (file)
@@ -25,6 +25,6 @@ define XENOMAI_PREPARE_KERNEL
                --verbose
 endef
 
-LINUX_POST_EXTRACT_HOOKS += XENOMAI_PREPARE_KERNEL
+LINUX_PRE_PATCH_HOOKS += XENOMAI_PREPARE_KERNEL
 
 endif #BR2_LINUX_EXT_XENOMAI