package/iperf3: fix musl build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 30 Jan 2016 18:27:56 +0000 (19:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Feb 2016 11:24:11 +0000 (12:24 +0100)
Ported -D_GNU_SOURCE from https://dev.openwrt.org/changeset/45103

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iperf3/0002-Fix-build-using-musl-libc.patch [new file with mode: 0644]
package/iperf3/iperf3.mk

diff --git a/package/iperf3/0002-Fix-build-using-musl-libc.patch b/package/iperf3/0002-Fix-build-using-musl-libc.patch
new file mode 100644 (file)
index 0000000..f220360
--- /dev/null
@@ -0,0 +1,43 @@
+From 1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sat, 30 Jan 2016 19:23:20 +0100
+Subject: [PATCH 1/1] Fix build using musl libc
+
+Fixes https://github.com/esnet/iperf/issues/331
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+Patch sent upstream: https://github.com/esnet/iperf/pull/344
+
+ src/cjson.h | 2 ++
+ src/timer.h | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/cjson.h b/src/cjson.h
+index d4449e6..7af19a9 100644
+--- a/src/cjson.h
++++ b/src/cjson.h
+@@ -23,6 +23,8 @@
+ #ifndef cJSON__h
+ #define cJSON__h
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C"
+ {
+diff --git a/src/timer.h b/src/timer.h
+index 0f9c5eb..9b22b7f 100644
+--- a/src/timer.h
++++ b/src/timer.h
+@@ -30,6 +30,7 @@
+ #ifndef __TIMER_H
+ #define __TIMER_H
++#include <stdint.h>
+ #include <sys/time.h>
+ /* TimerClientData is an opaque value that tags along with a timer.  The
+-- 
+2.7.0.rc3
+
index 885a5990f8bbbad043897a41223bfaac722c6f47..74d6cce2be16751dd5ac16fa76c610c7fb6a949d 100644 (file)
@@ -9,4 +9,6 @@ IPERF3_SITE = $(call github,esnet,iperf,$(IPERF3_VERSION))
 IPERF3_LICENSE = BSD-3c, BSD-2c, MIT
 IPERF3_LICENSE_FILES = LICENSE
 
+IPERF3_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
+
 $(eval $(autotools-package))