uclibc: re-add uclibc-update-config target
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 30 Apr 2014 19:18:57 +0000 (21:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 1 May 2014 21:36:30 +0000 (23:36 +0200)
Commit a5e92d92e7ee413157aae7cecf1f354e718731e1 converted uClibc to the
package infrastructure, but while doing so removed support for the
documented uclibc-update-config make target. This make target copies the
uclibc .config file back to the original (typically version-controlled)
configuration file.

As this was an unintentional removal, this patch re-adds the
uclibc-update-config target.

Reported-by: Dan Moulding <dan.moulding@rackwareinc.com>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/uclibc.mk

index 020e2180964c24aebacca36120cfdcfd9cf4fd4f..717cf53a88e0e5fc538aea0b4a21b1af73f11fdb 100644 (file)
@@ -211,7 +211,7 @@ endef
 endif
 
 #
-# Endianess
+# Endianness
 #
 
 ifeq ($(call qstrip,$(BR2_ENDIAN)),BIG)
@@ -553,5 +553,8 @@ uclibc-menuconfig: uclibc-patch
 
 $(eval $(generic-package))
 
+uclibc-update-config: $(UCLIBC_DIR)/.stamp_configured
+       cp -f $(UCLIBC_DIR)/.config $(UCLIBC_CONFIG_FILE)
+
 # Before uClibc is built, we must have the second stage cross-compiler
 $(UCLIBC_TARGET_BUILD): | host-gcc-intermediate