package/libmbim: bump to version 1.26.0
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 28 Jul 2021 07:45:50 +0000 (09:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 28 Jul 2021 19:05:42 +0000 (21:05 +0200)
This release introduces meson build system support that fixes
gobject-intorspection issue with autotools.

As meson files are only available in git, switch the location to
https://gitlab.freedesktop.org.

Since 1.26.0 libgudev is not required anymore so drop this dependency.

Add support for bash-completion.

Fixes:
http://autobuild.buildroot.net/results/f8a81aad0e262a567a2b31712575472ae92e5518

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: Aleksander Morgado <aleksander@aleksander.es>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libmbim/libmbim.hash
package/libmbim/libmbim.mk

index 2779be1e96dbaeefbcdcd98ee1c2f39d80afaa00..07cfd691638597bf680715a0472c4b1a9ba6cbb8 100644 (file)
@@ -1,4 +1,4 @@
 # Locally computed
-sha256  02590736163fff10e5732191fccc1b9920969616ddc59613a003052a116a3c25  libmbim-1.24.8.tar.xz
+sha256  63b53db0196dadea673f04524b0683ce40282f25bfd513d398e2a10b992cac01  libmbim-1.26.0.tar.gz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
index b343dec2389b304b5b204c673485b57b65cb91a3..cdc3fabedbe042f0155f6266887f9aa338c11001 100644 (file)
@@ -4,9 +4,8 @@
 #
 ################################################################################
 
-LIBMBIM_VERSION = 1.24.8
-LIBMBIM_SITE = https://www.freedesktop.org/software/libmbim
-LIBMBIM_SOURCE = libmbim-$(LIBMBIM_VERSION).tar.xz
+LIBMBIM_VERSION = 1.26.0
+LIBMBIM_SITE = https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/archive/$(LIBMBIM_VERSION)
 LIBMBIM_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (programs)
 LIBMBIM_LICENSE_FILES = COPYING COPYING.LIB
 LIBMBIM_CPE_ID_VENDOR = freedesktop
@@ -14,12 +13,18 @@ LIBMBIM_INSTALL_STAGING = YES
 
 LIBMBIM_DEPENDENCIES = libglib2
 
-# if libgudev available, request udev support
-ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
-LIBMBIM_DEPENDENCIES += libgudev
-LIBMBIM_CONF_OPTS += --with-udev
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBMBIM_DEPENDENCIES += gobject-introspection
+LIBMBIM_CONF_OPTS += -Dintrospection=true
 else
-LIBMBIM_CONF_OPTS += --without-udev
+LIBMBIM_CONF_OPTS += -Dintrospection=false
 endif
 
-$(eval $(autotools-package))
+ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)
+LIBMBIM_DEPENDENCIES += bash-completion
+LIBMBIM_CONF_OPTS += -Dbash_completion=true
+else
+LIBMBIM_CONF_OPTS += -Dbash_completion=false
+endif
+
+$(eval $(meson-package))