package/apache: add optional support for lua
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 30 Mar 2018 16:50:36 +0000 (18:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Mar 2018 18:17:09 +0000 (20:17 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/apache/apache.mk

index eaf7b9c5bf02664105c73777701a29fcfc1215c0..3b39be4a40a2b88839553e23afb8e36d62e31491 100644 (file)
@@ -40,7 +40,6 @@ APACHE_CONF_OPTS = \
        --without-suexec-bin \
        --enable-mods-shared=all \
        --with-mpm=$(APACHE_MPM) \
-       --disable-lua \
        --disable-luajit
 
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
@@ -57,6 +56,15 @@ APACHE_CONF_OPTS += \
        --disable-proxy-html
 endif
 
+ifeq ($(BR2_PACKAGE_LUA),y)
+APACHE_CONF_OPTS += \
+       --enable-lua \
+       --with-lua=$(STAGING_DIR)/usr
+APACHE_DEPENDENCIES += lua
+else
+APACHE_CONF_OPTS += --disable-lua
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 APACHE_DEPENDENCIES += openssl
 APACHE_CONF_OPTS += \