avahi: fix build with BR2_ENABLE_LOCALE
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Aug 2008 07:29:20 +0000 (07:29 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Aug 2008 07:29:20 +0000 (07:29 -0000)
package/avahi/Config.in
package/avahi/avahi.mk

index 245ff36695694c3ea969241085367de92fdf4168..4036801867b2ffdc1f2f8f3d9c2003a9e2467ba1 100644 (file)
@@ -1,6 +1,8 @@
 config BR2_PACKAGE_AVAHI
        bool "avahi"
        select BR2_PACKAGE_LIBDAEMON
+       select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+       select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
        help
          Avahi is a system which facilitates service
          discovery on a local network.
index 6c25b36ec647c97760da8b924bb7351915384171..2d95e933d1b83701c80a82fceb967fe050844a11 100644 (file)
@@ -142,7 +142,7 @@ $(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked $(AVAHI_EXTRA_DEPS)
        touch $@
 
 $(AVAHI_DIR)/.compiled: $(AVAHI_DIR)/.configured
-       $(MAKE) -C $(AVAHI_DIR)
+       $(MAKE) -C $(AVAHI_DIR) $(if $(BR2_ENABLE_LOCALE),LIBS=-lintl)
        touch $@
 
 $(AVAHI_DIR)/.installed: $(AVAHI_DIR)/.compiled
@@ -180,7 +180,7 @@ endif
                 $(TARGET_DIR)/usr/sbin/avahi-daemon
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
 
-avahi: uclibc libdaemon $(AVAHI_TARGETS)
+avahi: uclibc libdaemon $(AVAHI_TARGETS) $(if $(BR2_ENABLE_LOCALE),gettext libintl)
 
 avahi-clean:
        -$(MAKE) -C $(AVAHI_DIR) distclean