ecryptfs-utils: new package
authorMarcin Bis <marcin@bis.org.pl>
Fri, 31 May 2013 10:12:55 +0000 (10:12 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Jun 2013 21:16:46 +0000 (23:16 +0200)
The following patch adds support for ecryptfs-utils.
http://ecryptfs.org/

[Peter: needs host-intltool, fix typo in help text]
Signed-off-by: Marcin Bis <marcin@bis.org.pl>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/ecryptfs-utils/Config.in [new file with mode: 0644]
package/ecryptfs-utils/ecryptfs-utils.mk [new file with mode: 0644]

index 4233ff23ba4d11cb5c0097746fc39bf9ba201ae7..8a29c99aa572eb56d76536cfcea61b3a03d0f599 100644 (file)
@@ -195,6 +195,7 @@ source "package/cramfs/Config.in"
 source "package/curlftpfs/Config.in"
 source "package/dosfstools/Config.in"
 source "package/e2fsprogs/Config.in"
+source "package/ecryptfs-utils/Config.in"
 source "package/exfat/Config.in"
 source "package/exfat-utils/Config.in"
 source "package/f2fs-tools/Config.in"
diff --git a/package/ecryptfs-utils/Config.in b/package/ecryptfs-utils/Config.in
new file mode 100644 (file)
index 0000000..c10659a
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_ECRYPTFS_UTILS
+       bool "ecryptfs-utils"
+       select BR2_PACKAGE_KEYUTILS
+       select BR2_PACKAGE_LIBNSS
+       depends on BR2_USE_MMU # keyutils
+       depends on !BR2_avr32 && !BR2_microblaze # keyutils
+       depends on BR2_LARGEFILE # libnss
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libnss -> libnspr
+       help
+         eCryptfs is a POSIX-compliant enterprise cryptographic
+         filesystem for Linux. It is stacked on top of any other
+         Linux filesystem, it stores cryptographic metadata in the header
+         of each file written.
+
+         The eCryptfs kernel module is available in all Linux kernels
+         since version 2.6.19. This package provides userspace utilities
+         needed to mount eCryptfs.
+
+         Files are encrypted using a passphrase. Consider building openssl
+         for another method.
+
+         http://ecryptfs.org
diff --git a/package/ecryptfs-utils/ecryptfs-utils.mk b/package/ecryptfs-utils/ecryptfs-utils.mk
new file mode 100644 (file)
index 0000000..226c929
--- /dev/null
@@ -0,0 +1,28 @@
+#############################################################
+#
+# ecryptfs-utils
+#
+##############################################################
+
+ECRYPTFS_UTILS_VERSION         = 103
+ECRYPTFS_UTILS_SOURCE          = ecryptfs-utils_$(ECRYPTFS_UTILS_VERSION).orig.tar.gz
+ECRYPTFS_UTILS_SITE            = https://launchpad.net/ecryptfs/trunk/$(ECRYPTFS_UTILS_VERSION)/+download
+ECRYPTFS_UTILS_LICENSE         = GPLv2+
+ECRYPTFS_UTILS_LICENSE_FILES   = COPYING
+
+ECRYPTFS_UTILS_DEPENDENCIES    = keyutils libnss host-intltool
+ECRYPTFS_UTILS_CONF_OPT        = --disable-pywrap --disable-pam
+
+#Needed for build system to find pk11func.h and libnss3.so
+ECRYPTFS_UTILS_CONF_ENV = \
+  NSS_CFLAGS="-I$(STAGING_DIR)/usr/include/nss -I$(STAGING_DIR)/usr/include/nspr" \
+  NSS_LIBS="-lnss3"
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+       ECRYPTFS_UTILS_CONF_OPT += --enable-openssl
+       ECRYPTFS_UTILS_DEPENDENCIES += openssl
+else
+       ECRYPTFS_UTILS_CONF_OPT += --disable-openssl
+endif
+
+$(eval $(autotools-package))