Globally remove aclocal directories from target
authorMalte Starostik <m-starostik@versanet.de>
Sat, 24 Jul 2010 11:21:25 +0000 (13:21 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jul 2010 08:45:00 +0000 (10:45 +0200)
* Remove $(TARGET_DIR)/usr/share/aclocal from target-finalize when not
  installing devfiles and
* Remove some (now) redundant cleanup from individual packages

Signed-off-by: Malte Starostik <m-starostik@versanet.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
package/gettext/gettext.mk
package/libxml2/libxml2.mk
package/multimedia/speex/speex.mk

index 619d8ea03c907887b62ce61ed0de795994dd5351..f130325a4aeaba94788746ab2d8dad64d54d4ef8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -384,7 +384,7 @@ target-finalize:
 ifeq ($(BR2_HAVE_DEVFILES),y)
        ( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
 else
-       rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig
+       rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/aclocal
        find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
        find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
 endif
index 80215c89440087060af0ded13bd930e56fbacc99..2b308c84abff5585c804c06e20ccd643e6b4163f 100644 (file)
@@ -135,8 +135,6 @@ gettext-dirclean:
 gettext-target: $(GETTEXT_DIR)/$(GETTEXT_BINARY)
        $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GETTEXT_DIR) install
        chmod +x $(TARGET_DIR)/usr/lib/libintl.so* # identify as needing to be stripped
-       rm -rf $(addprefix $(TARGET_DIR),/usr/share/aclocal /usr/include/libintl.h)
-       rmdir --ignore-fail-on-non-empty $(TARGET_DIR)/usr/include
 
 $(TARGET_DIR)/usr/lib/libintl.so: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
        cp -dpf $(STAGING_DIR)/usr/lib/libgettext*.so* \
index 3a3e00706dade544a32de57454d58d4e608a2810..8f2513684cbbf155196007cbed3438737df0fbd0 100644 (file)
@@ -34,8 +34,7 @@ $(eval $(call AUTOTARGETS,package,libxml2,host))
 $(LIBXML2_HOOK_POST_INSTALL):
        $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xml2-config
        $(SED) "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xml2-config
-       rm -rf $(TARGET_DIR)/usr/share/aclocal
        touch $@
 
 # libxml2 for the host
-LIBXML2_HOST_BINARY:=$(HOST_DIR)/usr/bin/xmllint
\ No newline at end of file
+LIBXML2_HOST_BINARY:=$(HOST_DIR)/usr/bin/xmllint
index 6943ad7305c13a849849cd3e33cdebf87e7f25bc..e246b2491ebb5777ce0e83bcfc33c63b8d1788d6 100644 (file)
@@ -32,5 +32,5 @@ $(SPEEX_TARGET_BUILD): $(SPEEX_TARGET_CONFIGURE)
        $(Q)touch $@
 
 $(SPEEX_HOOK_POST_INSTALL): $(SPEEX_TARGET_INSTALL_TARGET)
-       rm -rf $(TARGET_DIR)/usr/share/doc/speex $(TARGET_DIR)/usr/share/aclocal
+       rm -rf $(TARGET_DIR)/usr/share/doc/speex
        touch $@