python, python3: fix unicodedata enabling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 12:03:27 +0000 (13:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 12:06:18 +0000 (13:06 +0100)
A confusion was made when applying commit
c3d539b53ff0533e91ae849dbdcdd589b0fec0cc ('host python/python3:
conditionally disable unicodedata') and then commit
73293e88c828c9bddc0b684a4603f86f70f8e876 ('python, python3: enable
unicodedata for host-python, needed by setuptools').

The first commit added the enabling of unicodedata in the host Python
when the target Python is configured with unicodedata, which is
necessary because building the target unicodedata Python module
requires having unicodedata support in the host Python.

The second commit enabled the unicodedata unconditionally in the host
Python, because it is needed by host-setuptools.

However, when the second commit was applied, the logic that consisted
in disabling unicodedate in the host Python when not needed was kept,
which resulted in breaking the build of host-setuptools due to the
lack of unicodedata support in the host python.

This commit fixes that by only leaving the unconditional
--enable-unicodedata in the host Python configuration options, and
therefore removing the problematic conditional --disable-unicodedata.

Fixes:

  http://autobuild.buildroot.org/results/b62/b622fc14776f5a6c26ff0d1fb882f4ae6cccc5d8/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python/python.mk
package/python3/python3.mk

index e177ef752209b9c48598e6a4c7c7be7adafbe66d..94765cbb84c5352a193aa3ba3dfea9d2d499ae0a 100644 (file)
@@ -89,7 +89,6 @@ endif
 
 ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
 PYTHON_CONF_OPT += --disable-unicodedata
-HOST_PYTHON_CONF_OPT += --disable-unicodedata
 endif
 
 # Default is UCS2 w/o a conf opt
index 24e90d68e76b416d0e579bf5fcb8a3405a903863..880b66e3c5ce6b0ae3fd6c207d19df574d9bc105 100644 (file)
@@ -77,7 +77,6 @@ endif
 
 ifneq ($(BR2_PACKAGE_PYTHON3_UNICODEDATA),y)
 PYTHON3_CONF_OPT += --disable-unicodedata
-HOST_PYTHON3_CONF_OPT += --disable-unicodedata
 endif
 
 ifeq ($(BR2_PACKAGE_PYTHON3_BZIP2),y)