Makefile: unexport RUBYOPT
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 11 Jul 2013 14:37:33 +0000 (11:37 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 12 Jul 2013 11:31:11 +0000 (13:31 +0200)
On Gentoo systems with ruby installed RUBYOPT is set and causes build
breakage for some packages that needs host-ruby (example: webkit).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index f6e99659488b0c956da9a0c197c89f4fc1870c9e..f477124935cff1aaef4a058c7669e2f72a0fa81b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -180,6 +180,9 @@ unexport PKG_CONFIG_SYSROOT_DIR
 # steps of some packages.
 unexport DESTDIR
 
+# Causes breakage with packages that needs host-ruby
+unexport RUBYOPT
+
 # bash prints the name of the directory on 'cd <dir>' if CDPATH is
 # set, so unset it here to not cause problems. Notice that the export
 # line doesn't affect the environment of $(shell ..) calls, so