release: don't include temp files
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 8 May 2020 08:32:20 +0000 (10:32 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 8 May 2020 09:33:31 +0000 (11:33 +0200)
When we prepare the release, we generate the manual in various formats,
so that it can be consulted locally without needing the miriads of tools
needed to generate it.

However, this creates the temporary .br2-external.* files in the output
directory, and those end up in the release tarball.

This is not a problem in practice, but is not clean.

Run 'distclean' in the output directory, to get rid of everything but
the generated documentation.

Reported-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 3aa4ba4532722b61335636ab304010eeae0277c9..2da34b53055332afe23d2e59e5b8e81dc0348099 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1190,7 +1190,7 @@ release: OUT = buildroot-$(BR2_VERSION)
 release:
        git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
        $(MAKE) O=$(OUT) manual-html manual-text manual-pdf
-       $(MAKE) O=$(OUT) clean
+       $(MAKE) O=$(OUT) distclean
        tar rf $(OUT).tar $(OUT)
        gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
        bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2