package: add fbterm, a framebuffer-based terminal emulator
authorDimitry Golubovsky <golubovsky@gmail.com>
Tue, 15 May 2012 16:36:06 +0000 (16:36 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 16 May 2012 07:59:49 +0000 (09:59 +0200)
[Peter: fix dependencies / white space]
Signed-off-by: Dmitry <golubovsky@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/fbterm/Config.in [new file with mode: 0644]
package/fbterm/fbterm.mk [new file with mode: 0644]

index 8cb3b22cb1a939a93864832d7f8e6e2d5cb04639..5d6250cbe164f6b1b3c46659c572da61201cc5c2 100644 (file)
@@ -112,6 +112,7 @@ source "package/fbgrab/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/fbset/Config.in"
 endif
+source "package/fbterm/Config.in"
 source "package/fbv/Config.in"
 source "package/imagemagick/Config.in"
 source "package/linux-fusion/Config.in"
diff --git a/package/fbterm/Config.in b/package/fbterm/Config.in
new file mode 100644 (file)
index 0000000..1e4ab4c
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_FBTERM
+       bool "fbterm"
+       depends on (BR2_INSTALL_LIBSTDCPP && BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
+       select BR2_PACKAGE_FONTCONFIG
+       select BR2_PACKAGE_LIBERATION
+       help
+         fbterm is a fast terminal emulator for Linux with frame buffer
+         device or VESA video card.
+
+         http://code.google.com/p/fbterm/
+
+comment "fbterm requires a toolchain with C++, WCHAR and locale support"
+       depends on !(BR2_INSTALL_LIBSTDCPP && BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
diff --git a/package/fbterm/fbterm.mk b/package/fbterm/fbterm.mk
new file mode 100644 (file)
index 0000000..ddb5b2b
--- /dev/null
@@ -0,0 +1,12 @@
+############################################
+#
+# fbterm
+#
+############################################
+
+FBTERM_VERSION = 1.7.0
+FBTERM_SITE = http://fbterm.googlecode.com/files/
+
+FBTERM_DEPENDENCIES = fontconfig liberation
+
+$(eval $(call AUTOTARGETS))