gstreamer1: add explicit libunwind support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 3 Nov 2016 09:58:28 +0000 (06:58 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 22:02:56 +0000 (23:02 +0100)
It's a new feature for 1.10.0+, however it doesn't have an
enable/disable configure switch so just handle the dependency.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gstreamer1/gstreamer1.mk

index f0afdd976cbed599a6eab8cbc6d2ce917da11974..cb111f2f4c6e1f84e728e6df01d39789cc323f05 100644 (file)
@@ -34,6 +34,11 @@ GSTREAMER1_CONF_OPTS = \
        $(if $(BR2_PACKAGE_GSTREAMER1_PLUGIN_REGISTRY),,--disable-registry) \
        $(if $(BR2_PACKAGE_GSTREAMER1_INSTALL_TOOLS),,--disable-tools)
 
-GSTREAMER1_DEPENDENCIES = libglib2 host-pkgconf host-bison host-flex
+GSTREAMER1_DEPENDENCIES = \
+       host-bison \
+       host-flex \
+       host-pkgconf \
+       libglib2 \
+       $(if $(BR2_PACKAGE_LIBUNWIND),libunwind)
 
 $(eval $(autotools-package))