package/perl-math-int64: new package
authorJoeri Barbarien <joeri.barbarien@nokia.com>
Mon, 7 Dec 2020 10:04:40 +0000 (11:04 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 21 Dec 2020 09:28:36 +0000 (10:28 +0100)
Signed-off-by: Joeri Barbarien <joeri.barbarien@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/perl-math-int64/Config.in [new file with mode: 0644]
package/perl-math-int64/perl-math-int64.hash [new file with mode: 0644]
package/perl-math-int64/perl-math-int64.mk [new file with mode: 0644]

index ad9670662752101dd183d710b2bf99a938822439..d0b4cd7531c801390940ef537d85ec2890c5ea08 100644 (file)
@@ -2515,6 +2515,7 @@ F:        package/perl-devel-size/
 F:     package/perl-i18n/
 F:     package/perl-locale-maketext-lexicon/
 F:     package/perl-lwp-protocol-https/
+F:     package/perl-math-int64/
 F:     package/perl-math-prime-util/
 F:     package/perl-mime-base64-urlsafe/
 F:     package/perl-mojolicious-plugin-authentication/
index ae4a41115ccec580de5cf1779ee3abbc267f1383..c3677dd15ef6f87d0b50a5f0c669bbc706df768e 100644 (file)
@@ -783,6 +783,7 @@ menu "Perl libraries/modules"
        source "package/perl-lwp-protocol-https/Config.in"
        source "package/perl-mail-dkim/Config.in"
        source "package/perl-mailtools/Config.in"
+       source "package/perl-math-int64/Config.in"
        source "package/perl-math-prime-util/Config.in"
        source "package/perl-mime-base64-urlsafe/Config.in"
        source "package/perl-mime-tools/Config.in"
diff --git a/package/perl-math-int64/Config.in b/package/perl-math-int64/Config.in
new file mode 100644 (file)
index 0000000..8fbea44
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PERL_MATH_INT64
+       bool "perl-math-int64"
+       depends on !BR2_STATIC_LIBS
+       help
+         Manipulate 64 bits integers in Perl.
+
+         http://metacpan.org/release/Math-Int64
+
+comment "perl-math-int64 needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-math-int64/perl-math-int64.hash b/package/perl-math-int64/perl-math-int64.hash
new file mode 100644 (file)
index 0000000..4f2374b
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5  1ad0ce8b5e903dfe9f7ffbabd8a43014  Math-Int64-0.54.tar.gz
+sha256  dcfc51e698437ea6b9cefe0276215c56cdb6a7f85e3e24a2b6b4189f1960d351  Math-Int64-0.54.tar.gz
+
+# computed by scancpan
+sha256  59feedfdc4f99a746c54e06ac46c4627fb1e29be3bc71756184f92333600f72b  COPYING
diff --git a/package/perl-math-int64/perl-math-int64.mk b/package/perl-math-int64/perl-math-int64.mk
new file mode 100644 (file)
index 0000000..749ff60
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-math-int64
+#
+################################################################################
+
+PERL_MATH_INT64_VERSION = 0.54
+PERL_MATH_INT64_SOURCE = Math-Int64-$(PERL_MATH_INT64_VERSION).tar.gz
+PERL_MATH_INT64_SITE = $(BR2_CPAN_MIRROR)/authors/id/S/SA/SALVA
+PERL_MATH_INT64_LICENSE = Artistic or GPL-1.0+
+PERL_MATH_INT64_LICENSE_FILES = COPYING
+PERL_MATH_INT64_DISTNAME = Math-Int64
+
+$(eval $(perl-package))