libee: new package
authorClayton Shotwell <clshotwe@rockwellcollins.com>
Wed, 12 Mar 2014 17:51:07 +0000 (12:51 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Mar 2014 22:20:39 +0000 (23:20 +0100)
[Peter: needs host-pkgconf to find libestr]
Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libee/Config.in [new file with mode: 0644]
package/libee/libee.mk [new file with mode: 0644]

index ad603e1dc30543fd3c9554ccb0e70fa25d671328..f73a558cf516855cc2331b533834aba7ac2c3eab 100644 (file)
@@ -764,6 +764,7 @@ source "package/libcap-ng/Config.in"
 source "package/libcgroup/Config.in"
 source "package/libcofi/Config.in"
 source "package/libdaemon/Config.in"
+source "package/libee/Config.in"
 source "package/libelf/Config.in"
 source "package/libev/Config.in"
 source "package/libevdev/Config.in"
diff --git a/package/libee/Config.in b/package/libee/Config.in
new file mode 100644 (file)
index 0000000..9a3411e
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_LIBEE
+       bool "libee"
+       select BR2_PACKAGE_LIBESTR
+       help
+         An Event Expression Library inspired by CEE.
+
+         CEE is an upcoming standard used to describe network
+         events in a number of normalized formats. It's goal is
+         to unify they currently many different representations
+         that exist in the industry.
+
+         The core idea of libee is to provide a small but hopefully
+         convenient API layer above the CEE standard. However, CEE
+         is not finished. At the time of this writing, CEE is under
+         heavy development and even some of its core data structures
+         (like the data dictionary and taxonmy) have not been fully
+         specified.
+
+         http://www.libee.org
diff --git a/package/libee/libee.mk b/package/libee/libee.mk
new file mode 100644 (file)
index 0000000..f6d36b6
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libee
+#
+################################################################################
+
+LIBEE_VERSION = 0.4.1
+LIBEE_SITE = http://www.libee.org/download/files/download/
+LIBEE_LICENSE = LGPLv2.1+
+LIBEE_LICENSE_FILES = COPYING
+LIBEE_DEPENDENCIES = libestr host-pkgconf
+LIBEE_INSTALL_STAGING = YES
+
+LIBEE_MAKE = $(MAKE1)
+
+$(eval $(autotools-package))