package/docker-cli: fix version info since move to 19.03.x
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 31 Aug 2020 06:58:41 +0000 (08:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 31 Aug 2020 13:16:47 +0000 (15:16 +0200)
Upstream changed the variables used when outputting version / git commit
info in docker version since:

 commit 04b5f44230162de40741acaa0f94c7af6f2fa1d5
 Author: Ian Campbell <ijc@docker.com>
 Date:   Tue Jan 8 15:03:51 2019 +0000

    Move versioning variables to a separate package.

    This helps to avoid circular includes, by separating the pure data out from the
    actual functionality in the cli subpackage, allowing other code which is
    imported to access the data.

Signed-off-by: Ian Campbell <ijc@docker.com>
    Upstream-commit: 20c19830a95455e8562551aad52c715ad0807cc6
    Component: cli

Which is included in docker-cli 19.3.x - So adjust the _CLI_LDFLAGS to match
to get proper docker version output:

Client:
 Version:           19.03.11
 API version:       1.40
 Go version:        go1.13.14
 Git commit:        19.03.11

vs:

Client:
 Version:           unknown-version
 API version:       1.40
 Go version:        go1.13.14
 Git commit:        unknown-commit

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/docker-cli/docker-cli.mk

index 1466b0afbdc2b315c4d736318f26a19417ac9525..766c984f0b5da8307c1ec35d865389124ac7351c 100644 (file)
@@ -17,8 +17,8 @@ DOCKER_CLI_TAGS = autogen
 DOCKER_CLI_BUILD_TARGETS = cmd/docker
 
 DOCKER_CLI_LDFLAGS = \
-       -X github.com/docker/cli/cli.GitCommit=$(DOCKER_CLI_VERSION) \
-       -X github.com/docker/cli/cli.Version=$(DOCKER_CLI_VERSION)
+       -X github.com/docker/cli/cli/version.GitCommit=$(DOCKER_CLI_VERSION) \
+       -X github.com/docker/cli/cli/version.Version=$(DOCKER_CLI_VERSION)
 
 ifeq ($(BR2_PACKAGE_DOCKER_CLI_STATIC),y)
 DOCKER_CLI_LDFLAGS += -extldflags '-static'