spandsp: fix static build with jpeg enabled
authorBaruch Siach <baruch@tkos.co.il>
Fri, 12 Oct 2018 04:39:50 +0000 (07:39 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 12 Oct 2018 19:58:19 +0000 (21:58 +0200)
When jpeg is enabled libtiff links with it, but the spandsp configure
test doesn't take that into account, so the configure test fails. Use
pkg-config to add the required tiff dependencies.

Fixes:
http://autobuild.buildroot.net/results/243/243f1d1271a767556e0a4cd56a42fcc8c1a371ed/
http://autobuild.buildroot.net/results/485/48527e144bc4ad3eaab807f302888380bd9e78bb/
http://autobuild.buildroot.net/results/058/05885325ec274cb9860d423c57eed5e7063aedc0/

Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/spandsp/spandsp.mk

index 4b1f89cf4b34681f212aef7ac12bbf59f72df490..fc9db34bfcae500d9dce59269a2dce7c510217e5 100644 (file)
@@ -10,8 +10,9 @@ SPANDSP_SITE = https://www.soft-switch.org/downloads/spandsp/snapshots
 SPANDSP_LICENSE = LGPL-2.1 (library), GPL-2.0 (test suite)
 SPANDSP_LICENSE_FILES = COPYING
 
-SPANDSP_DEPENDENCIES = tiff
+SPANDSP_DEPENDENCIES = tiff host-pkgconf
 SPANDSP_INSTALL_STAGING = YES
+SPANDSP_CONF_ENV = LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libtiff-4`"
 
 SPANDSP_CONF_OPTS = \
        --disable-doc \