sam-ba: create $(HOST_DIR)/bin before using it
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 18:03:26 +0000 (20:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 18:04:19 +0000 (20:04 +0200)
If one runs "make host-sam-ba" from a clean build, sam-ba.mk cannot
create its symbolic link because $(HOST_DIR)/bin doesn't exist. So
let's create this directory.

>>> host-sam-ba 2.16 Installing to host directory
mkdir -p /buildroot/output/host/opt/sam-ba/
cp -a /buildroot/output/build/host-sam-ba-2.16/* /buildroot/output/host/opt/sam-ba/
ln -sf ../opt/sam-ba/sam-ba_64 /buildroot/output/host/bin/sam-ba
ln: failed to create symbolic link '/buildroot/output/host/bin/sam-ba': No such file or directory
make[1]: *** [package/pkg-generic.mk:234: /buildroot/output/build/host-sam-ba-2.16/.stamp_host_installed] Error 1
make: *** [Makefile:79: _all] Error 2

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sam-ba/sam-ba.mk

index 11dbb7eef0a41c5be168d9d56c23a46f61b29e27..0d36b0dc593384cb83185d868fd37cba80049de5 100644 (file)
@@ -32,6 +32,7 @@ endif
 define HOST_SAM_BA_INSTALL_CMDS
        mkdir -p $(HOST_DIR)/opt/sam-ba/
        cp -a $(@D)/* $(HOST_DIR)/opt/sam-ba/
+       mkdir -p $(HOST_DIR)/bin/
        ln -sf ../opt/sam-ba/$(SAM_BA_BIN_NAME) $(HOST_DIR)/bin/sam-ba
 endef