package/upmpdcli: fix missing dependencies
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 15 Sep 2016 06:39:58 +0000 (08:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Sep 2016 11:34:46 +0000 (13:34 +0200)
Starting with version 1.2 upmpdcli depends on libmicrohttpd and jsoncpp.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/upmpdcli/Config.in
package/upmpdcli/upmpdcli.mk

index b075d7a413a343589ef058ee6123d02a8d02746a..48720347fd7d3b841fbb624fe54b09e404cfe5d8 100644 (file)
@@ -2,8 +2,10 @@ config BR2_PACKAGE_UPMPDCLI
        bool "upmpdcli"
        depends on BR2_USE_MMU # fork()
        depends on BR2_INSTALL_LIBSTDCPP
-       depends on BR2_TOOLCHAIN_HAS_THREADS # libupnpp -> libupnp
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libupnpp, libmicrohttpd
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
+       select BR2_PACKAGE_JSONCPP
+       select BR2_PACKAGE_LIBMICROHTTPD
        select BR2_PACKAGE_LIBMPDCLIENT
        select BR2_PACKAGE_LIBUPNPP
        help
index a7b98c9715686722e58dbe44124902b5508115fc..85b78fe0873998a62d5f811f1bb5390eebfcdf89 100644 (file)
@@ -8,7 +8,7 @@ UPMPDCLI_VERSION = 1.2.2
 UPMPDCLI_SITE = http://www.lesbonscomptes.com/upmpdcli/downloads
 UPMPDCLI_LICENSE = GPLv2+
 UPMPDCLI_LICENSE_FILES = COPYING
-UPMPDCLI_DEPENDENCIES = libmpdclient libupnpp
+UPMPDCLI_DEPENDENCIES = libmpdclient libupnpp libmicrohttpd jsoncpp
 
 ifeq ($(BR2_STATIC_LIBS),y)
 # Upmpdcli forgets to take the dependencies of libupnpp into