libical: use system time zone info
authorMarc Khouri <marc@khouri.ca>
Wed, 10 Aug 2016 14:30:16 +0000 (10:30 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 Aug 2016 22:02:31 +0000 (00:02 +0200)
libical requires time zone information in order to make use of time
zone functions (otherwise, segfaults occur when applications call
the time zone functions). This patch:
1. forces the system to build time zone info
2. ensures libical does not build its own time zone info (this is
   the default behaviour, but the flag is added in case libical's
   default changes in the future).

Signed-off-by: Marc Khouri <marc@khouri.ca>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libical/Config.in
package/libical/libical.mk

index 48170e9f87d75edeeca54c35dc3538e899f2c0c0..3220d5bee14aebc32d1357e266b47317fdedba7d 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_LIBICAL
        depends on BR2_INSTALL_LIBSTDCPP
        depends on !BR2_STATIC_LIBS
        depends on BR2_USE_WCHAR
+       select BR2_TARGET_TZ_INFO
        help
          libical is an Open Source (MPL/LGPL) implementation of the IETF's
          iCalendar Calendaring and Scheduling protocols.
index e8cb3f8d79f02d9e19baad5c54664be595fd9ea9..a511039569ccd431b99196858e5f80af2ad6a1a9 100644 (file)
@@ -13,5 +13,7 @@ LIBICAL_LICENSE_FILES = LICENSE
 # building without this option is broken, it is used by
 # Gentoo/alpinelinux as well
 LIBICAL_CONF_OPTS = -DSHARED_ONLY=true
+# never build time zone info, always use system's tzinfo
+LIBICAL_CONF_OPTS += -DUSE_BUILTIN_TZDATA=false
 
 $(eval $(cmake-package))