package/gnuradio: bump version to 3.7.9.1
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 5 Mar 2016 10:40:30 +0000 (11:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Mar 2016 13:51:33 +0000 (14:51 +0100)
Rebased patch #0001.
Removed patch #0002, applied upstream:
https://github.com/gnuradio/gnuradio/commit/3e2dc168467304212328abd061bf10f0c511f17f

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnuradio/0001-suppress-boost_unitest-detection.patch
package/gnuradio/0002-types_t-is-need-for-mode_t.patch [deleted file]
package/gnuradio/gnuradio.hash
package/gnuradio/gnuradio.mk

index 76638815abde11c25f1e3fdc2307d7ff3cba98b9..f1713dc349b32bd9e25a27bb0e74dbda3b4160fe 100644 (file)
@@ -7,8 +7,8 @@ Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
 ---
 Index: gnuradio-3.7.5/volk/cmake/VolkBoost.cmake
 ===================================================================
---- gnuradio-3.7.5.orig/volk/cmake/VolkBoost.cmake
-+++ gnuradio-3.7.5/volk/cmake/VolkBoost.cmake
+--- gnuradio-3.7.5.orig/volk/cmake/Modules/VolkBoost.cmake
++++ gnuradio-3.7.5/volk/cmake/Modules/VolkBoost.cmake
 @@ -29,7 +29,6 @@ set(__INCLUDED_VOLK_BOOST_CMAKE TRUE)
  set(BOOST_REQUIRED_COMPONENTS
      filesystem
@@ -21,20 +21,21 @@ Index: gnuradio-3.7.5/volk/lib/CMakeLists.txt
 ===================================================================
 --- gnuradio-3.7.5.orig/volk/lib/CMakeLists.txt
 +++ gnuradio-3.7.5/volk/lib/CMakeLists.txt
-@@ -540,8 +540,9 @@ endif(ENABLE_STATIC_LIBS)
+@@ -580,7 +580,10 @@
+ ########################################################################
  # Build the QA test application
  ########################################################################
+-if(ENABLE_TESTING)
++
 +find_package(Boost "1.35" COMPONENTS "unit_test_framework")
++
++if(ENABLE_TESTING AND BUILD_TEST)
  
--if(Boost_FOUND)
-+if(Boost_FOUND AND BUILD_TEST)
-     set_source_files_properties(
-         ${CMAKE_CURRENT_SOURCE_DIR}/testqa.cc PROPERTIES
-@@ -558,4 +559,4 @@ if(Boost_FOUND)
-     target_link_libraries(test_all volk ${Boost_LIBRARIES})
-     add_test(qa_volk_test_all test_all)
+     #include Boost headers
+     include_directories(${Boost_INCLUDE_DIRS})
+@@ -597,4 +600,4 @@
+         TARGET_DEPS volk
+     )
  
--endif(Boost_FOUND)
-+endif(Boost_FOUND AND BUILD_TEST)
+-endif(ENABLE_TESTING)
++endif(ENABLE_TESTING AND BUILD_TEST)
diff --git a/package/gnuradio/0002-types_t-is-need-for-mode_t.patch b/package/gnuradio/0002-types_t-is-need-for-mode_t.patch
deleted file mode 100644 (file)
index 7730d2d..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-To avoid :
-error: 'mode_t' has not been declared
-sys/types.h must be included 
-
-Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
----
-Index: gnuradio-3.7.5/gnuradio-runtime/include/gnuradio/logger.h.in
-===================================================================
---- gnuradio-3.7.5.orig/gnuradio-runtime/include/gnuradio/logger.h.in
-+++ gnuradio-3.7.5/gnuradio-runtime/include/gnuradio/logger.h.in
-@@ -44,6 +44,8 @@
- #ifdef _MSC_VER
- typedef unsigned short mode_t;
-+#else
-+#include <sys/types.h>
- #endif
- #include <gnuradio/api.h>
index d34dd55c3ac50b00e7022b62234f5bd0c1943d83..bb934e2b92aa26c9a131478a8a3f83cbb2a3f4f8 100644 (file)
@@ -1,5 +1,2 @@
-# From http://gnuradio.org/redmine/projects/gnuradio/files
-md5    b4a917a548f41ce25c6c88f9bc864bca        gnuradio-3.7.5.tar.gz
-
-# Locally calculated:
-sha256 467f62190687a34f9faa18be8d650e28d7046b94070b1b6d94355c28beb76243  gnuradio-3.7.5.tar.gz
+# From http://gnuradio.org/releases/gnuradio/sha256sums
+sha256 9c06f0f1ec14113203e0486fd526dd46ecef216dfe42f12d78d9b781b1ef967e        gnuradio-3.7.9.1.tar.gz
index b7dbcb9fdd518e3847ba019104d671a46a3fbc4a..46d1f4fab82ad89a740bdfe7598cfcaa6d65878c 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-GNURADIO_VERSION = 3.7.5
-GNURADIO_SITE = http://gnuradio.org/redmine/attachments/download/792
+GNURADIO_VERSION = 3.7.9.1
+GNURADIO_SITE = http://gnuradio.org/releases/gnuradio
 GNURADIO_LICENSE = GPLv3+
 GNURADIO_LICENSE_FILES = COPYING