package/libsndfile: fix c99 check
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 20 Jun 2021 18:04:09 +0000 (20:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 18 Jul 2021 11:57:10 +0000 (13:57 +0200)
Since the bump of libsndfile to version 1.0.31 in commit
8c600fda64f48c16d20588336dd7ac6a32241c6a, the check for c99 contains
"include <wchar.h>" although the package itself does not use wchar
functions outside Windows-specific code.  This patch forces the
detection of c99 for toolchains lacking wchar.

Fixes:
http://autobuild.buildroot.net/results/62c/62c07e66491e2fcf32d3921f8286ec1293591194/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libsndfile/libsndfile.mk

index 69530c98ededac77a3e266fa522a3ebb31ce8056..c955b9d08844ff9acf9359837eb0b6704bb81dad 100644 (file)
@@ -15,6 +15,7 @@ LIBSNDFILE_CPE_ID_VENDOR = libsndfile_project
 # disputed, https://github.com/erikd/libsndfile/issues/398
 LIBSNDFILE_IGNORE_CVES += CVE-2018-13419
 
+LIBSNDFILE_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 LIBSNDFILE_CONF_OPTS = \
        --disable-sqlite \
        --disable-alsa \