gst-plugins-good: Fix style issues and use of --disable-png.
authorDaniel Laird <danieljlaird@hotmail.com>
Fri, 23 Jan 2009 10:39:35 +0000 (10:39 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Fri, 23 Jan 2009 10:39:35 +0000 (10:39 -0000)
Update ordering and configure options.

Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index 5c6beac98e104f16cdee2e7040034532de65700b..d1dc763ee9929ae0704cddc231b6d7bfc913621f 100644 (file)
@@ -27,6 +27,20 @@ GST_PLUGINS_GOOD_CONF_OPT = \
 
 GST_PLUGINS_GOOD_DEPENDENCIES = gstreamer gst-plugins-base
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_JPEG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
+GST_PLUGINS_GOOD_DEPENDENCIES += jpeg
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PNG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-libpng
+GST_PLUGINS_GOOD_DEPENDENCIES += libpng
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-libpng
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_BZ2),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-bz2
 GST_PLUGINS_GOOD_DEPENDENCIES += bzip2
@@ -41,20 +55,6 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_JPEG),y)
-GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
-GST_PLUGINS_GOOD_DEPENDENCIES += jpeg
-else
-GST_PLUGINS_GOOD_CONF_OPT += --disable-jpeg
-endif
-
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PNG),y)
-GST_PLUGINS_GOOD_CONF_OPT += --enable-png
-GST_PLUGINS_GOOD_DEPENDENCIES += libpng
-else
-GST_PLUGINS_GOOD_CONF_OPT += --disable-png
-endif
-
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOFILTER),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-videofilter
 else