download: get rid of trailing slash removal hack for FOO_SITE
authorLuca Ceresoli <luca@lucaceresoli.net>
Sat, 3 Oct 2015 17:22:18 +0000 (19:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Oct 2015 14:46:40 +0000 (15:46 +0100)
Not needed anymore since the URLs have been cleared, the manual states
they are illegal and a check has been introduced to notice future
mistakes.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index de2fb0705b5983e017f626fe246e06d8069498b9..3942a89b39a001e99866320b3b0f22bf35de3df8 100644 (file)
@@ -388,7 +388,7 @@ endif
 $(2)_ALL_DOWNLOADS = \
        $$(foreach p,$$($(2)_SOURCE) $$($(2)_PATCH) $$($(2)_EXTRA_DOWNLOADS),\
                $$(if $$(findstring ://,$$(p)),$$(p),\
-                       $$($(2)_SITE:/=)/$$(p)))
+                       $$($(2)_SITE)/$$(p)))
 
 ifndef $(2)_SITE
  ifdef $(3)_SITE