package/belle-sip: fix build failure due to gcc bug 99410
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Fri, 5 Mar 2021 15:15:29 +0000 (16:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Mar 2021 15:46:46 +0000 (16:46 +0100)
The belle-sip package exhibits gcc bug 99410 when built for the Nios2
architecture with optimization enabled, which causes a build failure.

As done for other packages in Buildroot work around this gcc bug by
setting optimization to -O0 if BR2_TOOLCHAIN_HAS_GCC_BUG_99410=y.

Fixes:
http://autobuild.buildroot.net/results/71f26fd81db8e9b19b3f18f3f3cefd9c768f094f/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/belle-sip/belle-sip.mk

index b5169be48891f55ee8aedf16bf29df4826b5d1ba..23b60e51f546bdda7951dd585c4602da66c8da49 100644 (file)
@@ -32,4 +32,12 @@ else ifeq ($(BR2_SHARED_LIBS),y)
 BELLE_SIP_CONF_OPTS += -DENABLE_SHARED=ON -DENABLE_STATIC=OFF
 endif
 
+BELLE_SIP_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_99140),y)
+BELLE_SIP_CFLAGS += -O0
+endif
+
+BELLE_SIP_CONF_OPTS += -DCMAKE_C_FLAGS="$(BELLE_SIP_CFLAGS)"
+
 $(eval $(cmake-package))