package/opencv3: fix build with protobuf and gcc < 6
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 26 Dec 2020 10:25:00 +0000 (11:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Dec 2020 13:11:22 +0000 (14:11 +0100)
Fix the folloing build failure with protobuf (enabled since commit
31c68a449ecd7da61ecfd909bea7ce799f9a6450) and gcc 5.3.0:

[ 53%] Building CXX object modules/dnn/CMakeFiles/opencv_dnn.dir/opencv-caffe.pb.cc.o
In file included from /home/peko/autobuild/instance-1/output-1/per-package/opencv3/host/opt/ext-toolchain/mips64el-buildroot-linux-uclibc/include/c++/5.5.0/atomic:38:0,
                 from /home/peko/autobuild/instance-1/output-1/per-package/opencv3/host/mips64el-buildroot-linux-uclibc/sysroot/usr/include/google/protobuf/io/coded_stream.h:115,
                 from /home/peko/autobuild/instance-1/output-1/build/opencv3-3.4.12/buildroot-build/modules/dnn/opencv-caffe.pb.h:23,
                 from /home/peko/autobuild/instance-1/output-1/build/opencv3-3.4.12/buildroot-build/modules/dnn/opencv-caffe.pb.cc:4:
/home/peko/autobuild/instance-1/output-1/per-package/opencv3/host/opt/ext-toolchain/mips64el-buildroot-linux-uclibc/include/c++/5.5.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
 #error This file requires compiler and library support \
  ^

Fixes:
 - http://autobuild.buildroot.org/results/7caf175af039054a032b8f63b458b3940d9ec0f3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/opencv3/opencv3.mk

index 231d44395eb7175e9dac4216ebf9a73b0baaf368..b1b86ba71dd4089472bdddf8be0de2e99b288f0e 100644 (file)
@@ -287,7 +287,9 @@ OPENCV3_CONF_OPTS += -DWITH_PNG=OFF
 endif
 
 ifeq ($(BR2_PACKAGE_OPENCV3_WITH_PROTOBUF),y)
+# protobuf needs c++11 (since 3.6.0)
 OPENCV3_CONF_OPTS += \
+       -DENABLE_CXX11=ON \
        -DPROTOBUF_UPDATE_FILES=ON \
        -DWITH_PROTOBUF=ON
 OPENCV3_DEPENDENCIES += protobuf