Revert "package/pkg-meson: handle b_pie"
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 May 2021 09:16:35 +0000 (11:16 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 May 2021 09:16:35 +0000 (11:16 +0200)
This reverts commit a8a147f6046f9d11d4685ddfa5c2a6a01f4d7219.

That commit incorrectly made use of BR2_TOOLCHAIN_SUPPORTS_PIE, when it
should have been using BR2_PIC_PIE.

Besides, another attempt is pending, that unconditionally disables it as
it will be set by the toolchain wrapper already.

For both reasons, revert rather than switch over to BR2_PIC_PIE.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-meson.mk

index a55063d58ed5a396f75cea934690796b30c717fc..a57820d4d296d6e7cb4e22d17399c5dfb0d0d4f3 100644 (file)
@@ -91,7 +91,6 @@ define $(2)_CONFIGURE_CMDS
                --default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
                --buildtype=$(if $(BR2_ENABLE_DEBUG),debug,release) \
                --cross-file=$$($$(PKG)_SRCDIR)/build/cross-compilation.conf \
-               -Db_pie=$(if $(BR2_TOOLCHAIN_SUPPORTS_PIE),true,false) \
                -Dstrip=false \
                -Dbuild.pkg_config_path=$$(HOST_DIR)/lib/pkgconfig \
                $$($$(PKG)_CONF_OPTS) \