sdl: Fix host variant dependencies
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Thu, 27 Mar 2014 22:27:42 +0000 (23:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Mar 2014 22:38:10 +0000 (23:38 +0100)
The host variant of sdl inherited the dependencies and conf opt from
sdl which could lead to some trouble.

For example:
  If you were to build host-sdl and had alsa-lib enabled in your
  packages list, it would try to build host-alsa-lib which does not
  exists.

This patch define basic dependencies and conf opt for the host variant.

Reported-by: Eric Limpens <limpens@gmail.com>
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl/sdl.mk

index d5fb3311c5d022a0e122d5ad9d8625ebbc7f58e3..086f5e98a792949eae7832f5a83e435effc684dd 100644 (file)
@@ -21,6 +21,7 @@ SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
 HOST_SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
 
 SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
+HOST_SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
 
 ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
 SDL_CONF_OPT += --enable-video-fbcon=yes
@@ -70,6 +71,12 @@ SDL_CONF_OPT += --enable-pulseaudio=no \
                --disable-nasm \
                --disable-video-ps3
 
+HOST_SDL_CONF_OPT += --enable-pulseaudio=no \
+               --disable-arts \
+               --disable-esd \
+               --disable-nasm \
+               --disable-video-ps3
+
 SDL_CONFIG_SCRIPTS = sdl-config
 
 # Remove the -Wl,-rpath option.