package/python-gpiozero: bump version to 1.6.2
authorPeter Seiderer <ps.report@gmx.net>
Fri, 9 Apr 2021 21:12:58 +0000 (23:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 22 Apr 2021 19:34:49 +0000 (21:34 +0200)
- update license file hash:
  @@ -1,3 +1,5 @@
  +SPDX-License-Identifier: BSD-3-Clause
  +

- add setuptools runtime dependency, fixes:

$ pinout -r a020d3 -m
Traceback (most recent call last):
  File "/usr/bin/pinout", line 6, in <module>
    from pkg_resources import load_entry_point
ModuleNotFoundError: No module named 'pkg_resources'

For details see [1].

[1] https://gpiozero.readthedocs.io/en/stable/changelog.html

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-gpiozero/Config.in
package/python-gpiozero/python-gpiozero.hash
package/python-gpiozero/python-gpiozero.mk

index 4d60855bfebe19b23db130a05261790b1b2de427..13506ae45f16536cde5459eda938695c7760510f 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_PYTHON_GPIOZERO
        depends on BR2_PACKAGE_PYTHON3 # python-colorzero
        select BR2_PACKAGE_PYTHON_COLORZERO # runtime
        select BR2_PACKAGE_PYTHON_RPI_GPIO # runtime
+       select BR2_PACKAGE_PYTHON_SETUPTOOLS # runtime
        help
          A simple interface to GPIO devices with Raspberry Pi.
 
index 23020035610c3390e0d21b9f5305fc91cbcf1e3b..7359f6405ecba35f70c1ae9b34b622610f999f95 100644 (file)
@@ -1,4 +1,4 @@
 # Locally computed
-sha256  8cb9824fe1b08e7935de03899455e20ce2c242e4cebb0c954c274c48059f6ea5  python-gpiozero-1.5.1.tar.gz
+sha256  7e6da923774437e24edc0c056e486415bace8c4ba4123c22ac4214147854ea6d  python-gpiozero-1.6.2.tar.gz
 # Locally computed
-sha256  b6e26763b79d7904d6eaa66f7f53ae374cf30431bb6ba8bcb0d9d5ff56dc69e3  LICENSE.rst
+sha256  b6fdd587f3dc3a9b8cc5adae00918e3ffa909b1092bd4decf7e8b1b08fa5d0fb  LICENSE.rst
index 67e8067a8b88618abafec4a04b8f91cd6c2b457d..a68c39db1f5d9806c43c0a7c7929e894c2dc37a6 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PYTHON_GPIOZERO_VERSION = 1.5.1
+PYTHON_GPIOZERO_VERSION = 1.6.2
 PYTHON_GPIOZERO_SITE = $(call github,gpiozero,gpiozero,v$(PYTHON_GPIOZERO_VERSION))
 PYTHON_GPIOZERO_LICENSE = BSD-3-Clause
 PYTHON_GPIOZERO_LICENSE_FILES = LICENSE.rst