gst1-plugins-bad: fix egl detection
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 22 Jun 2015 19:42:54 +0000 (21:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 22 Jun 2015 20:13:33 +0000 (22:13 +0200)
Some egl implementations needs special compiler flags or defines (E.G.
mesa3d for wayland needs to pass -DMESA_EGL_NO_X11_HEADERS to not try to
include X11 headers).  This is correctly included in the .pc file, but the
configure logic doesn't use pkg-config so help it along.

Likewise, some implementations may need to link against other libraries, so
also pass LIBS.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index db323b97ca377dae09080772815c6767c4dae93f..faf0e2ae0323850ce47c354c621399ca6209baf3 100644 (file)
@@ -118,6 +118,9 @@ endif
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_EGL),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-egl
 GST1_PLUGINS_BAD_DEPENDENCIES += libegl
+GST1_PLUGINS_BAD_CONF_ENV += \
+       CPPFLAGS="$(TARGET_CPPFLAGS) $(shell $(PKG_CONFIG_HOST_BINARY) --cflags egl)" \
+       LIBS="$(shell $(PKG_CONFIG_HOST_BINARY) --libs egl)"
 else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-egl
 endif