package/libclc: disable ccache
authorAdam Duskett <Aduskett@gmail.com>
Mon, 6 Apr 2020 16:50:44 +0000 (09:50 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:13:57 +0000 (22:13 +0200)
Configure.py extracts arch, vendor, and os from the passed
toolchain string on line 180. When using ccache, the passed path string is
"/usr/lib64/ccache/g++" which breaks the logic, causing the following error:

Traceback (most recent call last):
  File "./configure.py", line 180, in <module>
    (t_arch, t_vendor, t_os) = target.split('-')
ValueError: not enough values to unpack (expected 3, got 1)

Use --with-cxx-compiler=$(HOSTCXX_NOCCACHE) instead of $(HOSTCXX) to fix the
above error.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libclc/libclc.mk

index 52249a7087a7e8623e7817d6e35e5729ffec3c28..630616905cd0c189be0e57812d37c10e8a50bbd0 100644 (file)
@@ -25,7 +25,7 @@ LIBCLC_CONF_OPTS = \
        --prefix=/usr \
        --includedir=/usr/share \
        --pkgconfigdir=/usr/lib/pkgconfig \
-       --with-cxx-compiler=$(HOSTCXX)
+       --with-cxx-compiler=$(HOSTCXX_NOCCACHE)
 
 define LIBCLC_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure.py $(LIBCLC_CONF_OPTS))