package/musl: bump to version 1.1.23
authorJörg Krause <joerg.krause@embedded.rocks>
Tue, 30 Jul 2019 10:23:30 +0000 (12:23 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Jul 2019 15:53:07 +0000 (17:53 +0200)
This version merges the RISC-V (64-bit) port and new math library
implementations of log, exp, and pow. Internals of how (non-cancellable)
syscalls are performed have been overhauled so that all code necessary to make
the syscall resides in the arch-provided header and is inlinable. In the
process, bugs in the implementation of mips and microblaze syscall mechanisms
were found and fixed. Several other bugs were fixed as well, including a
potentially serious one in the layout of static TLS for shared libraries on
archs that use "TLS variant I" layout.

A couple behaviors that were clearly undesirable but arguably mandated by POSIX
have been fixed as a result of POSIX intepretations rendering them unnecessary.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Tested-by: Mark Corbin <mark.corbin@embecosm.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/musl/musl.hash
package/musl/musl.mk

index 56444017708812f18e7599fcbf38a96709ea0152..034393edd996e2c36b0b4038fc6fe5e6bc238770 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated after checking pgp signature from
-# http://www.musl-libc.org/releases/musl-1.1.22.tar.gz.asc
-sha256  8b0941a48d2f980fd7036cfbd24aa1d414f03d9a0652ecbd5ec5c7ff1bee29e3  musl-1.1.22.tar.gz
+# http://www.musl-libc.org/releases/musl-1.1.23.tar.gz.asc
+sha256  8a0feb41cef26c97dde382c014e68b9bb335c094bbc1356f6edaaf6b79bd14aa  musl-1.1.23.tar.gz
 sha256  a3ae1b9fc5d4938f5734734383b9813d27a5652df23010c6f9d4c5419b239a41  COPYRIGHT
index 5db5bbd26511ef45d6844e2725174842790504eb..b401fb3d11cc8366a4eb1956f64181c81bff2971 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-MUSL_VERSION = 1.1.22
+MUSL_VERSION = 1.1.23
 MUSL_SITE = http://www.musl-libc.org/releases
 MUSL_LICENSE = MIT
 MUSL_LICENSE_FILES = COPYRIGHT